Let’s Start Programming! Forums CATIA Macro Programming Exporting data to Excel

This topic contains 2 replies, has 2 voices, and was last updated by  lal 2 years, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1546

    lal
    Participant

    Hi! I am now able to get data with my macro and I would like to export them to Excel but I have a problem.

    The main problem is to export a formula. Into Emmett Ross’s book it is written to use .Formula ex:

    Excel.Cells(2,13).Formula= “=NOW()”

    But when I try to do so, my column is empty:

    ExcelSheet1.Application.Cells(1, 1).Formula = “=RECHERCHEV(B1;export_articles.csv!$A:$B;2;FAUX)”

    (the formula works fine on Excel)
    By the way, I would like to change B1 by Bi with i the number of the row.

    Do you have any idea to help me ? 🙂

    #1547

    Emmett Ross
    Keymaster

    So you’ve tried this exact code and nothing happens:

    If you use the code above, do you get the text in cell A1 but nothing in cell C1?

    #1551

    lal
    Participant

    Hum, in fact I resolved my problem (which wasn’t one). I’m French but it is not possible to use Excel Macro in French. So I have to use VLOOKUP (instead of RECHERCHEV) and use , and . instead of ; and ,

Viewing 3 posts - 1 through 3 (of 3 total)

The forum ‘CATIA Macro Programming’ is closed to new topics and replies.